summaryrefslogtreecommitdiff
path: root/package/linux-tools
diff options
context:
space:
mode:
authorJulien BOIBESSOT <julien.boibessot@armadeus.com>2017-12-08 12:52:18 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-12-12 07:29:34 +0100
commite47741d1a349653c68c37842865f870604fe0c47 (patch)
treee84c7408bcade520fcb10614658727ab446be662 /package/linux-tools
parent4b09fe60d9ca812b75f62b090853258fc5924ba9 (diff)
package/linux-tools: fixes build of iio with 4.14+ kernels
Since Linux kernel commit [1], the build of the iio tool has been changed to use the common Linux tools build system. The installation directory is now given by DESTDIR, like for all other Linux tools. We keep the INSTALL_DIR environment in the 'install' target to be compatible with kernels older than 4.14. [1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=18956cf2d78a8d4a5959e20240f04ce8d5a6c121 Signed-off-by: Julien BOIBESSOT <julien.boibessot@armadeus.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/linux-tools')
-rw-r--r--package/linux-tools/linux-tool-iio.mk.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/linux-tools/linux-tool-iio.mk.in b/package/linux-tools/linux-tool-iio.mk.in
index 60d6249d2f..a8cc89e830 100644
--- a/package/linux-tools/linux-tool-iio.mk.in
+++ b/package/linux-tools/linux-tool-iio.mk.in
@@ -19,9 +19,11 @@ define IIO_BUILD_CMDS
$(IIO_MAKE_OPTS)
endef
+# DESTDIR used since kernel version 4.14
define IIO_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/iio \
$(IIO_MAKE_OPTS) \
INSTALL_ROOT=$(TARGET_DIR) \
+ DESTDIR=$(TARGET_DIR) \
install
endef