summaryrefslogtreecommitdiff
path: root/package/libphidget
diff options
context:
space:
mode:
authorJonathan Ben Avraham <yba@tkos.co.il>2014-08-27 13:18:29 +0300
committerPeter Korsgaard <peter@korsgaard.com>2014-08-28 08:39:48 +0200
commit1f7ea83e1363a48050cff9d7b0a2496237a1d96c (patch)
treecc63185dd5525edff9c14d273c472b89107c9805 /package/libphidget
parent2278046471c56f72a0244636e12dd2bd8cee33f1 (diff)
new package: libphidget
[Peter: order alphabetically] Signed-off-by: Jonathan Ben-Avraham <yba@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libphidget')
-rw-r--r--package/libphidget/Config.in24
-rw-r--r--package/libphidget/libphidget.mk16
2 files changed, 40 insertions, 0 deletions
diff --git a/package/libphidget/Config.in b/package/libphidget/Config.in
new file mode 100644
index 0000000000..9f3e4bf701
--- /dev/null
+++ b/package/libphidget/Config.in
@@ -0,0 +1,24 @@
+config BR2_PACKAGE_LIBPHIDGET
+ bool "libphidget"
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
+ select BR2_PACKAGE_LIBUSB
+ help
+ The libphidget library provides an API for controlling Phidgets
+ USB devices. The library translates API function calls to libusb
+ function calls to control attached Phidgets devices that provide
+ GPIO's, DAC's, accelerometers, servo motors, and other capabilities
+ either singly or on combo devices.
+
+ To use libphidget for controlling locally attached devices you
+ need to set up the userspace USB device tree /dev/bus/usb. See
+ file udev/99-phidgets.rules.
+
+ The libphidget library also contains an API for sending commands
+ to a local or remote phidgetwebservice using HTTP. The
+ phidgetwebservice then translates HTTP requests to libphidget API
+ function calls to control locally attached Phidgets devices.
+
+ http://phidgets.com/
+
+comment "libphidget needs a toolchain w/ threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libphidget/libphidget.mk b/package/libphidget/libphidget.mk
new file mode 100644
index 0000000000..ee5796e580
--- /dev/null
+++ b/package/libphidget/libphidget.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libphidget
+#
+################################################################################
+
+LIBPHIDGET_VERSION = 2.1.8.20140319
+LIBPHIDGET_SOURCE = libphidget_$(LIBPHIDGET_VERSION).tar.gz
+LIBPHIDGET_SITE = http://www.phidgets.com/downloads/libraries/
+LIBPHIDGET_DEPENDENCIES = libusb
+LIBPHIDGET_CONF_OPT = --disable-ldconfig
+LIBPHIDGET_INSTALL_STAGING = YES
+LIBPHIDGET_LICENSE = LGPLv3
+LIBPHIDGET_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))