summaryrefslogtreecommitdiff
path: root/package/libpam-tacplus
diff options
context:
space:
mode:
authorGiovanni Zantedeschi <giovanni.zantedeschi@datacom.ind.br>2015-08-20 13:16:26 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-28 11:22:45 +0200
commit8b2990217e22cea11bfc72d6913e3bc6615c5650 (patch)
tree6b13bf7f4d4e56c53972569480d2ccc26ba37fa6 /package/libpam-tacplus
parent90251cda02acbcda49ba5c267d045e6d09bff066 (diff)
libpam-tacplus: new package
[Thomas: - change the inclusion location in package/Config.in to be with the other linux-pam plugins. - fix indentation of the Config.in file. - fix build of the package when a toolchain without SSP support is used. - fix installation location of the PAM module: it was installed in /usr/lib/security, while all other PAM modules are in /lib/security. - adjust the ordering of the variables in the .mk file to be a bit more logical. - remove passing of $(TARGET_CONFIGURE_OPTS) in <pkg>_CONF_ENV as it is not needed: it is already done by the autotools-package infrastructure.] Signed-off-by: Giovanni Zantedeschi <giovanni.zantedeschi@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libpam-tacplus')
-rw-r--r--package/libpam-tacplus/Config.in9
-rw-r--r--package/libpam-tacplus/libpam-tacplus.mk21
2 files changed, 30 insertions, 0 deletions
diff --git a/package/libpam-tacplus/Config.in b/package/libpam-tacplus/Config.in
new file mode 100644
index 0000000000..2d80809d3b
--- /dev/null
+++ b/package/libpam-tacplus/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LIBPAM_TACPLUS
+ bool "libpam-tacplus"
+ help
+ TACACS+ protocol client library and PAM module in C. This
+ PAM module support authentication, authorization (account
+ management) and accounting (session management)performed
+ using TACACS+ protocol designed by Cisco.
+
+ https://github.com/jeroennijhof/pam_tacplus
diff --git a/package/libpam-tacplus/libpam-tacplus.mk b/package/libpam-tacplus/libpam-tacplus.mk
new file mode 100644
index 0000000000..6696d89887
--- /dev/null
+++ b/package/libpam-tacplus/libpam-tacplus.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# libpam-tacplus
+#
+################################################################################
+
+LIBPAM_TACPLUS_VERSION = 1.3.9
+LIBPAM_TACPLUS_SITE = $(call github,jeroennijhof,pam_tacplus,$(LIBPAM_TACPLUS_VERSION))
+LIBPAM_TACPLUS_LICENSE = GPLv2+
+LIBPAM_TACPLUS_LICENSE_FILES = COPYING
+LIBPAM_TACPLUS_DEPENDENCIES = linux-pam
+# Fetching from github, we need to generate the configure script
+LIBPAM_TACPLUS_AUTORECONF = YES
+LIBPAM_TACPLUS_AUTORECONF_OPTS = -I m4
+LIBPAM_TACPLUS_INSTALL_STAGING = YES
+LIBPAM_TACPLUS_CONF_ENV = \
+ ax_cv_check_cflags___fstack_protector_all=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
+LIBPAM_TACPLUS_CONF_OPTS = \
+ --enable-pamdir=/lib/security
+
+$(eval $(autotools-package))