summaryrefslogtreecommitdiff
path: root/package/libmicrohttpd
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2018-11-10 17:00:28 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-11-11 21:59:00 +0100
commit2e57e835bf26a8f554033f8c1998d1a34fce16a5 (patch)
tree5ecd3ca8973f1f3da832c86d9a07b12fa65d09a8 /package/libmicrohttpd
parente9b70f96e8200956c871810d7b7a60017b9b974d (diff)
libmicrohttpd: fix build on riscv
Define _REENTRANT like already done for ARC otherwise pthread detection will fail Fixes: - https://autobuild.buildroot.org/results/910dc7164312637bf4dcd89e4cb476ae198466c8 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/libmicrohttpd')
-rw-r--r--package/libmicrohttpd/libmicrohttpd.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libmicrohttpd/libmicrohttpd.mk b/package/libmicrohttpd/libmicrohttpd.mk
index 1cda434819..c22ad08478 100644
--- a/package/libmicrohttpd/libmicrohttpd.mk
+++ b/package/libmicrohttpd/libmicrohttpd.mk
@@ -11,10 +11,10 @@ LIBMICROHTTPD_INSTALL_STAGING = YES
LIBMICROHTTPD_CONF_OPTS = --disable-curl --disable-examples
LIBMICROHTTPD_CFLAGS = $(TARGET_CFLAGS) -std=c99
-# gcc on arc doesn't define _REENTRANT when -pthread is passed while
+# gcc on arc and riscv doesn't define _REENTRANT when -pthread is passed while
# it should. Compensate this deficiency here otherwise libmicrohttpd
# configure script doesn't find that thread support is enabled.
-ifeq ($(BR2_arc),y)
+ifeq ($(BR2_arc)$(BR2_riscv),y)
LIBMICROHTTPD_CFLAGS += -D_REENTRANT
endif