summaryrefslogtreecommitdiff
path: root/package/libcgi
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:48:13 +0100
commit665e13c85e1fd216499cdd335a88a4d1c20f175f (patch)
tree5ecc87c54905105b96cbe9891028ef8eb3d713b1 /package/libcgi
parent2d23d40279be39f70553974de11a5fc088622911 (diff)
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/libcgi')
-rw-r--r--package/libcgi/libcgi.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libcgi/libcgi.mk b/package/libcgi/libcgi.mk
index f46a1fa74c..7cb3417382 100644
--- a/package/libcgi/libcgi.mk
+++ b/package/libcgi/libcgi.mk
@@ -9,7 +9,7 @@ LIBCGI_SITE = http://downloads.sourceforge.net/project/libcgi/libcgi/$(LIBCGI_VE
LIBCGI_INSTALL_STAGING = YES
# use cross CC/AR rather than host
LIBCGI_MAKE_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS)" AR="$(TARGET_AR)" \
- $(if $(BR2_PREFER_STATIC_LIB),STATIC=1)
+ $(if $(BR2_STATIC_LIBS),STATIC=1)
LIBCGI_LICENSE = LGPLv2.1+
$(eval $(autotools-package))