summaryrefslogtreecommitdiff
path: root/package/imx-usb-loader
diff options
context:
space:
mode:
authorVincent Prince <vincent.prince.fr@gmail.com>2018-05-16 11:16:05 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-05-19 22:41:21 +0200
commit430ac895487dda261e6f68a066fd27847165d545 (patch)
tree3675b02161c252ff199e1d9dcc427b4f0b783a6c /package/imx-usb-loader
parentae7e5960a31795707ebdff5952b01881bffbf484 (diff)
imx-usb-loader: allow building the target variant
Having imx-usb-loader on the target might be useful when you're building a system that itself will be responsible for booting/flashing i.MX based devices. Signed-off-by: Vincent Prince <vincent.prince.fr@gmail.com> [Thomas: - improve commit log - fix indentation - drop BR2_arm dependency - add missing host-pkgconf dependency - fix prefix variable to install in $(TARGET_DIR)/usr] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/imx-usb-loader')
-rw-r--r--package/imx-usb-loader/Config.in9
-rw-r--r--package/imx-usb-loader/imx-usb-loader.mk10
2 files changed, 19 insertions, 0 deletions
diff --git a/package/imx-usb-loader/Config.in b/package/imx-usb-loader/Config.in
new file mode 100644
index 0000000000..6f083f34d1
--- /dev/null
+++ b/package/imx-usb-loader/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_IMX_USB_LOADER
+ bool "imx-usb-loader"
+ select BR2_PACKAGE_LIBUSB
+ help
+ This package contains tools to download and execute code
+ on Freescale i.MX5/i.MX6 and Vybrid SoCs through the
+ Serial Download Protocol.
+
+ https://github.com/boundarydevices/imx_usb_loader
diff --git a/package/imx-usb-loader/imx-usb-loader.mk b/package/imx-usb-loader/imx-usb-loader.mk
index 946a1f3d55..01a654e6cf 100644
--- a/package/imx-usb-loader/imx-usb-loader.mk
+++ b/package/imx-usb-loader/imx-usb-loader.mk
@@ -8,14 +8,24 @@ IMX_USB_LOADER_VERSION = 7e77787c83288a421080a9bf2f67063931f561be
IMX_USB_LOADER_SITE = $(call github,boundarydevices,imx_usb_loader,$(IMX_USB_LOADER_VERSION))
IMX_USB_LOADER_LICENSE = LGPL-2.1+
IMX_USB_LOADER_LICENSE_FILES = COPYING
+IMX_USB_LOADER_DEPENDENCIES = libusb host-pkgconf
HOST_IMX_USB_LOADER_DEPENDENCIES = host-libusb host-pkgconf
+define IMX_USB_LOADER_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
define HOST_IMX_USB_LOADER_BUILD_CMDS
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
+define IMX_USB_LOADER_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) prefix=$(TARGET_DIR)/usr install
+endef
+
define HOST_IMX_USB_LOADER_INSTALL_CMDS
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
endef
+$(eval $(generic-package))
$(eval $(host-generic-package))