summaryrefslogtreecommitdiff
path: root/package/imx-usb-loader
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-02 13:11:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-02 13:11:41 +0200
commit2acb231eaec310f80980e3f1d0eccb4136bf02f2 (patch)
tree986a5b6989c02717180e18504aa5c21f63dd3c1c /package/imx-usb-loader
parent5fd9f81fec0e8136342f9c412bcb65161ef95bc6 (diff)
imx-usb-loader: fix build issue
host-imx-usb-loader uses pkg-config to find libusb-1.0, but since it's a host package, pkg-config needs to be passed the appropriate environment variables, which are in $(HOST_CONFIGURE_OPTS). Therefore, we now pass $(HOST_CONFIGURE_OPTS) in the environment when building host-imx-usb-loader. Fixes: http://autobuild.buildroot.org/results/fba/fba11afe003c512ed5c529c417f3a0feb920b0ed/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/imx-usb-loader')
-rw-r--r--package/imx-usb-loader/imx-usb-loader.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/imx-usb-loader/imx-usb-loader.mk b/package/imx-usb-loader/imx-usb-loader.mk
index 4b60505317..fdabb6af30 100644
--- a/package/imx-usb-loader/imx-usb-loader.mk
+++ b/package/imx-usb-loader/imx-usb-loader.mk
@@ -11,7 +11,7 @@ IMX_USB_LOADER_LICENSE_FILES = COPYING
IMX_USB_LOADER_DEPENDENCIES = host-libusb
define HOST_IMX_USB_LOADER_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+ $(HOST_MAKE_ENV) $(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
define HOST_IMX_USB_LOADER_INSTALL_CMDS