summaryrefslogtreecommitdiff
path: root/package/guile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 14:47:18 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-27 17:19:47 +0100
commit64973b0946cefb06915674bc87a7a9ce5bf70699 (patch)
tree2a17ab1e35eec3f0d15e1fa0e9672362f29dea32 /package/guile
parent159cdbd5a3b3a14b004a6df2ce4bf202fb4cb592 (diff)
guile: fix libltdl, libgmp and libunistring detection
Explicitly pass the path to libtldl, libgmp and libunistring, so that guile does not try to use host versions when available. Fixes: http://autobuild.buildroot.org/results/056/056b7fcbf3b73a8d15ca635b000771cdc2d7fbf9/ And another similar problem with libgmp and libunistring. [Thomas: added --with-libunistring-prefix, as suggested by Samuel Martin.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Tested-by: Samuel Martin <s.martin49@gmail.com>
Diffstat (limited to 'package/guile')
-rw-r--r--package/guile/guile.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/guile/guile.mk b/package/guile/guile.mk
index 30af11d263..e57c9171ff 100644
--- a/package/guile/guile.mk
+++ b/package/guile/guile.mk
@@ -29,5 +29,10 @@ GUILE_CFLAGS = \
GUILE_CONF_ENV += GUILE_FOR_BUILD=$(HOST_DIR)/usr/bin/guile \
CFLAGS="$(TARGET_CFLAGS) $(GUILE_CFLAGS)"
+GUILE_CONF_OPTS += \
+ --with-libltdl-prefix=$(STAGING_DIR)/usr/lib \
+ --with-libgmp-prefix=$(STAGING_DIR)/usr/lib \
+ --with-libunistring-prefix=$(STAGING_DIR)/usr/lib
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))