summaryrefslogtreecommitdiff
path: root/package/gettext
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-07-18 23:02:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-19 11:35:22 +0200
commitbea8f267d550290c994d9616b98bb9c1cd9e03ba (patch)
tree81321b7a2a4e1674fcd29d90326501a54c27e0b6 /package/gettext
parent4638e2b97f783346c2c9e18f233a35755e49e7dc (diff)
infra/pkg-autotools: cleanup the gettextize step
Align the way we call gettextize to the way we call autoreconf: - provide the $(GETTEXTIZE) variable - pass $(HOST_CONFIGURE_OPTS) in the environment - pass the fully-qualified path to autom4te - use of -f even if the package provides its own options Some eye-candy in the output of gettextize. Thanks to Gustavo for pointing out the discrepancy between the way we call gettextize and the way we call autoreconf, and to Thomas for the live debug session. ;-) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gettext')
-rw-r--r--package/gettext/gettext.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/gettext/gettext.mk b/package/gettext/gettext.mk
index c8ef765870..121d25dcc4 100644
--- a/package/gettext/gettext.mk
+++ b/package/gettext/gettext.mk
@@ -57,6 +57,12 @@ endef
GETTEXT_POST_INSTALL_TARGET_HOOKS += GETTEXT_REMOVE_UNNEEDED
+define GETTEXT_GETTEXTIZE_EYE_CANDY
+ $(SED) '/Press Return\|read dummy/d' $(HOST_DIR)/usr/bin/gettextize
+endef
+
+HOST_GETTEXT_POST_INSTALL_HOOKS += GETTEXT_GETTEXTIZE_EYE_CANDY
+
# Force build with NLS support, otherwise libintl is not built
# This is needed because some packages (eg. libglib2) requires
# locales, but do not properly depend on BR2_ENABLE_LOCALE, and
@@ -72,5 +78,7 @@ define HOST_GETTEXT_GETTEXTIZE_CONFIRMATION
endef
HOST_GETTEXT_POST_INSTALL_HOOKS += HOST_GETTEXT_GETTEXTIZE_CONFIRMATION
+GETTEXTIZE = $(HOST_CONFIGURE_OPTS) AUTOM4TE=$(HOST_DIR)/usr/bin/autom4te $(HOST_DIR)/usr/bin/gettextize -f
+
$(eval $(autotools-package))
$(eval $(host-autotools-package))