summaryrefslogtreecommitdiff
path: root/package/fwup
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2017-05-28 17:00:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-05-31 21:59:08 +0200
commit682405ec762bf5659b69e7c1f2852502dcf80372 (patch)
tree86876bdec96aa823c3792769713bbe075488bc58 /package/fwup
parentfdabb80e4267f43f112d3c97c4692f5396b5fcf8 (diff)
package/fwup: bump version to 0.14.3
Added patch to fix uclibc build. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fwup')
-rw-r--r--package/fwup/0001-Fix-uclibc-build.patch36
-rw-r--r--package/fwup/fwup.hash2
-rw-r--r--package/fwup/fwup.mk2
3 files changed, 38 insertions, 2 deletions
diff --git a/package/fwup/0001-Fix-uclibc-build.patch b/package/fwup/0001-Fix-uclibc-build.patch
new file mode 100644
index 0000000000..f7bf245049
--- /dev/null
+++ b/package/fwup/0001-Fix-uclibc-build.patch
@@ -0,0 +1,36 @@
+From 0301cb4ffbf4705316ba017516745a535d66d552 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sun, 28 May 2017 16:56:39 +0200
+Subject: [PATCH 1/1] Fix uclibc build
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Without sys/types.h the build breaks with errors like this:
+
+parse_file.h:28:5: error: unknown type name ‘off_t’
+ off_t *map;
+ ^
+
+Patch sent upstream: https://github.com/fhunleth/fwup/pull/61
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ src/sparse_file.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/sparse_file.h b/src/sparse_file.h
+index 21bf5f9..579fbaa 100644
+--- a/src/sparse_file.h
++++ b/src/sparse_file.h
+@@ -18,6 +18,7 @@
+ #define SPARSE_FILE_H
+
+ #include <confuse.h>
++#include <sys/types.h>
+
+ struct sparse_file_map
+ {
+--
+2.11.0
+
diff --git a/package/fwup/fwup.hash b/package/fwup/fwup.hash
index e21eff0a6d..8679dcb265 100644
--- a/package/fwup/fwup.hash
+++ b/package/fwup/fwup.hash
@@ -1,2 +1,2 @@
# Locally calculated
-sha256 64c3a0ac38dc11c0c05b2588a89638cbc37f5552ac0f1c290f7ee5365f2bba49 fwup-v0.8.2.tar.gz
+sha256 cf2e6ff729c21bc000dbe008211cf9d4901be9b42c82a06e4068deb638ea8f6e fwup-v0.14.3.tar.gz
diff --git a/package/fwup/fwup.mk b/package/fwup/fwup.mk
index 0c2b0f9198..e47ecbe6dc 100644
--- a/package/fwup/fwup.mk
+++ b/package/fwup/fwup.mk
@@ -4,7 +4,7 @@
#
################################################################################
-FWUP_VERSION = v0.8.2
+FWUP_VERSION = v0.14.3
FWUP_SITE = $(call github,fhunleth,fwup,$(FWUP_VERSION))
FWUP_LICENSE = Apache-2.0
FWUP_LICENSE_FILES = LICENSE