summaryrefslogtreecommitdiff
path: root/package/fio
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-19 23:38:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-19 23:38:41 +0200
commit71122f537d2ff93f206818c8d91e06f55fe2b5e2 (patch)
tree8461752804a876c74054e1d7e2a7b4ec177e5e91 /package/fio
parent2631219f648f4aa13fa36d06a483e4507cb6f3d7 (diff)
fio: add optional dependency on libaio
fio can automatically detect and use libaio when available, so this commit makes this optional dependency explicit. Suggested by Charles <ckhardin@exablox.com> in bug #8851. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/fio')
-rw-r--r--package/fio/fio.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/fio/fio.mk b/package/fio/fio.mk
index acebb6fe70..6c4ad6c4ca 100644
--- a/package/fio/fio.mk
+++ b/package/fio/fio.mk
@@ -9,6 +9,10 @@ FIO_SITE = git://git.kernel.dk/fio.git
FIO_LICENSE = GPLv2 + special obligations
FIO_LICENSE_FILES = COPYING
+ifeq ($(BR2_PACKAGE_LIBAIO),y)
+FIO_DEPENDENCIES += libaio
+endif
+
define FIO_CONFIGURE_CMDS
(cd $(@D); ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
endef