summaryrefslogtreecommitdiff
path: root/package/clang
diff options
context:
space:
mode:
authorValentin Korenblit <valentin.korenblit@smile.fr>2018-05-11 13:47:52 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-05-11 23:22:01 +0200
commit95fc31239962ae488b159f83e8fc436c10b1128c (patch)
tree2d87abd3cc8e23107a33bf8778f3cf44838eab8b /package/clang
parent439e2add6c39bb128e1a5f1fb624ecfb99948d5e (diff)
package/clang: link libclang against libLLVM.so
libclang.so is statically linking against all LLVM static libraries instead of linking dynamically against libLLVM.so. This patch fixes this problem by setting LLVM_LINK_LLVM_DYLIB to ON. Signed-off-by: Valentin Korenblit <valentin.korenblit@smile.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/clang')
-rw-r--r--package/clang/clang.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/clang/clang.mk b/package/clang/clang.mk
index 8d86c5edda..14d6441c9a 100644
--- a/package/clang/clang.mk
+++ b/package/clang/clang.mk
@@ -85,5 +85,9 @@ define HOST_CLANG_INSTALL_CLANG_TBLGEN
endef
HOST_CLANG_POST_INSTALL_HOOKS = HOST_CLANG_INSTALL_CLANG_TBLGEN
+# This option must be enabled to link libclang dynamically against libLLVM.so
+HOST_CLANG_CONF_OPTS += -DLLVM_LINK_LLVM_DYLIB=ON
+CLANG_CONF_OPTS += -DLLVM_LINK_LLVM_DYLIB=ON
+
$(eval $(cmake-package))
$(eval $(host-cmake-package))