summaryrefslogtreecommitdiff
path: root/package/asterisk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-09-09 23:39:21 +0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2017-09-23 19:20:18 +0200
commit9b12a77ff81728ab914cf21d963aacc697f868c7 (patch)
tree46b57655c79af6062e8c0f1961eaee8d854748e0 /package/asterisk
parentc5a4355c739a4d38547329eeb6e36c10f1a85795 (diff)
package/asterisk: add optional portaudio dependency
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/asterisk')
-rw-r--r--package/asterisk/asterisk.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/asterisk/asterisk.mk b/package/asterisk/asterisk.mk
index 82ca2ba739..de3a0d5291 100644
--- a/package/asterisk/asterisk.mk
+++ b/package/asterisk/asterisk.mk
@@ -84,7 +84,6 @@ ASTERISK_CONF_OPTS = \
--without-postgres \
--without-pjproject \
--without-popt \
- --without-portaudio \
--without-pri \
--without-pwlib \
--without-radius \
@@ -173,6 +172,13 @@ else
ASTERISK_CONF_OPTS += --without-opus
endif
+ifeq ($(BR2_PACKAGE_PORTAUDIO),y)
+ASTERISK_DEPENDENCIES += portaudio
+ASTERISK_CONF_OPTS += --with-portaudio
+else
+ASTERISK_CONF_OPTS += --without-portaudio
+endif
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
ASTERISK_DEPENDENCIES += openssl
ASTERISK_CONF_OPTS += --with-ssl