summaryrefslogtreecommitdiff
path: root/package/alsa-lib
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:48:13 +0100
commit665e13c85e1fd216499cdd335a88a4d1c20f175f (patch)
tree5ecc87c54905105b96cbe9891028ef8eb3d713b1 /package/alsa-lib
parent2d23d40279be39f70553974de11a5fc088622911 (diff)
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/alsa-lib')
-rw-r--r--package/alsa-lib/alsa-lib.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/alsa-lib/alsa-lib.mk b/package/alsa-lib/alsa-lib.mk
index 0b329cd4b4..2890a38cae 100644
--- a/package/alsa-lib/alsa-lib.mk
+++ b/package/alsa-lib/alsa-lib.mk
@@ -18,7 +18,7 @@ ALSA_LIB_CONF_OPTS = --with-alsa-devdir=$(call qstrip,$(BR2_PACKAGE_ALSA_LIB_DEV
--without-versioned
# Can't build with static & shared at the same time (1.0.25+)
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ifeq ($(BR2_STATIC_LIBS),y)
ALSA_LIB_CONF_OPTS += --enable-shared=no
else
ALSA_LIB_CONF_OPTS += --enable-static=no