summaryrefslogtreecommitdiff
path: root/package/alljoyn-base
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2019-03-31 14:18:10 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-04-01 22:46:38 +0200
commitf72be49830404fb69480a9e5db4381dfcc6dc8ec (patch)
tree0e2ebfbe1bfe9d63ff02c221f132f8379374d025 /package/alljoyn-base
parent62797bd01a9f0f62f4bb7d52ad666ac82ffee17c (diff)
package/scons: remove python from SCONS
Remove $(HOST_DIR)/bin/python from SCONS variable to allow each scons package to select their python interpreter. Indeed, most of the scons packages (alljoyn, benejson, gpsd) only supports python2 Fixes: - http://autobuild.buildroot.org/results/b45f9fb69615b80758adeff4571e170c3bd9356b - http://autobuild.buildroot.org/results/13144a7ebd64ef7889312053f06a14047eea232d Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/alljoyn-base')
-rw-r--r--package/alljoyn-base/alljoyn-base.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/alljoyn-base/alljoyn-base.mk b/package/alljoyn-base/alljoyn-base.mk
index ad19802823..64ba647ab0 100644
--- a/package/alljoyn-base/alljoyn-base.mk
+++ b/package/alljoyn-base/alljoyn-base.mk
@@ -11,7 +11,7 @@ ALLJOYN_BASE_SITE = \
# See https://allseenalliance.org/alliance/ip-policy
ALLJOYN_BASE_LICENSE = ISC
-ALLJOYN_BASE_DEPENDENCIES = host-scons alljoyn openssl
+ALLJOYN_BASE_DEPENDENCIES = host-python host-scons alljoyn openssl
ALLJOYN_BASE_INSTALL_STAGING = YES
ALLJOYN_BASE_CRYPTO = openssl
@@ -68,7 +68,7 @@ endif
define ALLJOYN_BASE_BUILD_CMDS
$(foreach target,$(ALLJOYN_BASE_TARGETS),\
- cd $(@D)/$(target); $(SCONS) $(ALLJOYN_BASE_SCONS_OPTS)
+ cd $(@D)/$(target); $(HOST_DIR)/bin/python2 $(SCONS) $(ALLJOYN_BASE_SCONS_OPTS)
)
endef