summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2019-05-21 00:17:11 +0200
committerPeter Korsgaard <peter@korsgaard.com>2019-05-24 23:15:38 +0200
commitf26dc16ab4d087c8c3217c6d94cdc69d98aac2cf (patch)
tree17831af5706463e1fa7cb956dcd89b91982342c5 /linux
parent7c5dfea804af7b3a8f24092a27c1ff63b62b3f70 (diff)
linux: build after intel-microcode if enabled for early loading support
To support building in (a subset of) the intel-microcode files into the kernel using the CONFIG_EXTRA_FIRMWARE option, we need to ensure that the microcode files are installed before the Linux kernel is built. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 51fd41fa15..dd182d06b2 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -64,7 +64,8 @@ LINUX_MAKE_ENV = \
BR_BINARIES_DIR=$(BINARIES_DIR)
LINUX_INSTALL_IMAGES = YES
-LINUX_DEPENDENCIES = host-kmod
+LINUX_DEPENDENCIES = host-kmod \
+ $(if $(BR2_PACKAGE_INTEL_MICROCODE),intel-microcode)
# Starting with 4.16, the generated kconfig paser code is no longer
# shipped with the kernel sources, so we need flex and bison, but