summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-03-06 22:28:15 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-03-14 22:13:47 +0100
commit4ed7246a597325cea2c5b4624b7c94c67ca8662d (patch)
tree0a414d2b82f14248f8636cdfcb378c935457e37b /linux
parent1b94e8dcb368cd71d8002427bf4a150a2f082aa2 (diff)
linux{, -headers}: support downloads of v5+
With the arrival of linux v5.0, we need yet another condition to set _SITE correctly. Instead of continuing this madness, solve the problem generically: use v2.6 for 2.6.*, and use the number before the first dot in the other cases. While we're at it, remove the comment which has been incorrect since 80d7b68167a5c8893e906ace6b5f0b0166336406 (7 years ago). Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Jan Kundrát <jan.kundrat@cesnet.cz> Tested-by: Adam Duskett <aduskett@gmail.com> Reviewed-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk9
1 files changed, 2 insertions, 7 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 2b5d096e14..c7081db88f 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -37,15 +37,10 @@ else ifneq ($(findstring -rc,$(LINUX_VERSION)),)
LINUX_SITE = https://git.kernel.org/torvalds/t
else
LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
-# In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
-# to use the $(word) function. We support versions such as 4.0, 3.1,
-# 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.
ifeq ($(findstring x2.6.,x$(LINUX_VERSION)),x2.6.)
LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v2.6
-else ifeq ($(findstring x3.,x$(LINUX_VERSION)),x3.)
-LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v3.x
-else ifeq ($(findstring x4.,x$(LINUX_VERSION)),x4.)
-LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v4.x
+else
+LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/v$(firstword $(subst ., ,$(LINUX_VERSION))).x
endif
endif