summaryrefslogtreecommitdiff
path: root/fs/iso9660
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-12-28 11:40:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2018-01-03 21:58:07 +0100
commitb6842c40977886058f3471973397872c880a0ddc (patch)
tree4fcb6516c80eb8c516ab11d56b6b1af04c65570d /fs/iso9660
parent9fc21664e850f0999c4aa358235ab2b73f4bfb60 (diff)
fs: make it behave a bit more like the package infra
Currently, to register a filesystem, one has to call: $(eval $(call ROOTFS_TARGET,blabla)) This is very unlike the package infrastructure, where the name of the package is automatically guessed by the infra. It turns out that we can now do that for the filesystem infra too. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/iso9660')
-rw-r--r--fs/iso9660/iso9660.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 38ed3cd970..207c6aa39f 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -144,4 +144,4 @@ endef
ROOTFS_ISO9660_POST_GEN_HOOKS += ROOTFS_ISO9660_GEN_HYBRID
endif
-$(eval $(call ROOTFS_TARGET,iso9660))
+$(eval $(rootfs))