summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorMirza Krak <mirza.krak@northern.tech>2019-02-06 14:23:58 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-03-17 17:21:10 +0100
commitaba08cd218315c8ce5ec97c5e2dd5edbcfa47fdd (patch)
tree701f759f7e0f9b991b4d62190e327f82a45522fb /docs
parent8291bc77930a5ef87f98d1ff97c486dddfcdb244 (diff)
package/pkg-golang: add support for building host packages
With this you can add: $(eval $(host-golang-package)) to a package .mk file to build for host. Signed-off-by: Mirza Krak <mirza.krak@northern.tech> Acked-by: Angelo Compagnucci <angelo@amarulasolutions.com> Tested-by: Angelo Compagnucci <angelo@amarulasolutions.com> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com> Tested-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-golang.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/docs/manual/adding-packages-golang.txt b/docs/manual/adding-packages-golang.txt
index ae90eb7d4f..8c467689be 100644
--- a/docs/manual/adding-packages-golang.txt
+++ b/docs/manual/adding-packages-golang.txt
@@ -52,8 +52,11 @@ If you need CGO support in your package, you must add a dependency on
+BR2_PACKAGE_HOST_GO_TARGET_CGO_LINKING_SUPPORTS+.
The main macro of the Go package infrastructure is
-+golang-package+. It is similar to the +generic-package+ macro. Only
-target packages are supported with +golang-package+.
++golang-package+. It is similar to the +generic-package+ macro. The
+ability to build host packages is also available, with the
++host-golang-package+ macro.
+Host packages built by +host-golang-package+ macro should depend on
+BR2_PACKAGE_HOST_GO_HOST_ARCH_SUPPORTS.
Just like the generic infrastructure, the Go infrastructure works
by defining a number of variables before calling the +golang-package+.