summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorShyam Saini <shyam.saini@amarulasolutions.com>2019-04-18 18:53:31 +0530
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-04-20 22:21:37 +0200
commite471c6709d558efc0e3a78173f8f74a73e5e9df3 (patch)
treef0edd99935865c7f855411b299c33d9bcddc0905 /boot
parente2f9cc634863607b063d55562abcf465e80ba148 (diff)
boot/uboot: add support for having host-python-pyelftools as a dependency
Rockchip rk3399 SOC based boards require python pyelftools library for parsing dtb files, so lets add it as uboot dependency. This commit introduces a new config option BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS to achieve this. Signed-off-by: Shyam Saini <shyam.saini@amarulasolutions.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/uboot/Config.in8
-rw-r--r--boot/uboot/uboot.mk4
2 files changed, 12 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index d4a93615ee..33b7e67ff7 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -151,6 +151,14 @@ config BR2_TARGET_UBOOT_NEEDS_PYLIBFDT
Select this option if your U-Boot board configuration
requires the Python libfdt library to be available.
+config BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS
+ bool "U-Boot needs pyelftools"
+ help
+ Select this option if your U-Boot board configuration
+ requires the Python pyelftools library to be available.
+ This is used by some rockchip SOCs for elf parsing.
+ For example: rk3399 soc boards.
+
config BR2_TARGET_UBOOT_NEEDS_OPENSSL
bool "U-Boot needs OpenSSL"
help
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 3c070b41b3..ae09c37d84 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -152,6 +152,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYLIBFDT),y)
UBOOT_DEPENDENCIES += host-python host-swig
endif
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_PYELFTOOLS),y)
+UBOOT_DEPENDENCIES += host-python-pyelftools
+endif
+
ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
UBOOT_DEPENDENCIES += host-openssl
endif