summaryrefslogtreecommitdiff
path: root/arch
diff options
context:
space:
mode:
authorMark Corbin <mark.corbin@embecosm.com>2018-09-12 11:22:53 +0100
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-09-23 22:17:57 +0200
commitbd0640a2139119e2fdb4b384ebf32d1edcb0fdaa (patch)
treefa749570d2cab3be1ac74bcc9b35a534846a6821 /arch
parent1eca624c03e5e1f815e0e62cbfc3b99f3cd628b3 (diff)
arch: allow GCC target options to be optionally overwritten
The BR2_GCC_TARGET_* configuration variables are copied to corresponding GCC_TARGET_* variables which may then be optionally modified or overwritten by architecture specific makefiles. All makefiles must use the new GCC_TARGET_* variables instead of the BR2_GCC_TARGET_* versions. Signed-off-by: Mark Corbin <mark.corbin@embecosm.com> [Thomas: simplify include of arch/arch.mk] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'arch')
-rw-r--r--arch/arch.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/arch/arch.mk b/arch/arch.mk
new file mode 100644
index 0000000000..2429567b24
--- /dev/null
+++ b/arch/arch.mk
@@ -0,0 +1,17 @@
+# Allow GCC target configuration settings to be optionally
+# overwritten by architecture specific makefiles.
+
+# Makefiles must use the GCC_TARGET_* variables below instead
+# of the BR2_GCC_TARGET_* versions.
+GCC_TARGET_ARCH := $(call qstrip,$(BR2_GCC_TARGET_ARCH))
+GCC_TARGET_ABI := $(call qstrip,$(BR2_GCC_TARGET_ABI))
+GCC_TARGET_NAN := $(call qstrip,$(BR2_GCC_TARGET_NAN))
+GCC_TARGET_FP32_MODE := $(call qstrip,$(BR2_GCC_TARGET_FP32_MODE))
+GCC_TARGET_CPU := $(call qstrip,$(BR2_GCC_TARGET_CPU))
+GCC_TARGET_CPU_REVISION := $(call qstrip,$(BR2_GCC_TARGET_CPU_REVISION))
+GCC_TARGET_FPU := $(call qstrip,$(BR2_GCC_TARGET_FPU))
+GCC_TARGET_FLOAT_ABI := $(call qstrip,$(BR2_GCC_TARGET_FLOAT_ABI))
+GCC_TARGET_MODE := $(call qstrip,$(BR2_GCC_TARGET_MODE))
+
+# Include any architecture specific makefiles.
+-include $(sort $(wildcard arch/arch.mk.*))