summaryrefslogtreecommitdiff
path: root/arch
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-09-03 11:53:50 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-11-24 22:39:56 +0100
commit31b134a64537b1f6f38cd9378f4ddf0f43b22b43 (patch)
tree5f36d83a4a9c4f618a828cbe68c6fd506c2c27b0 /arch
parent5e6de23e45b2b39a39b00ff80ac6e884be89b62c (diff)
arch/mips: inverse the NaN logic
Currently the possibility to choose the NaN encoding is conditional to having a sufficiently recent gcc version. Which means that the architecture selection depends on the gcc version. But that's opposite to what we've always done in Buildroot: the software versions are conditional to the architecture options. There is nothing we can do about the hardware: it is there, we can't change it, while we can restrict ourselves to using software that is working on said hardware. Thus, we inverse the logic, to move the condition onto the software side: whenever NaN-2008 are selected, we restrict the toolchain selection to at least a gcc-4.9. But now, the option with the NaN type is always set, so we must enclose the code in gcc.mk inside a HAS_NAN_OPTION condition, as is already done for the external toolchain case. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'arch')
-rw-r--r--arch/Config.in.mips2
1 files changed, 1 insertions, 1 deletions
diff --git a/arch/Config.in.mips b/arch/Config.in.mips
index c08b2a2968..13d1a477e6 100644
--- a/arch/Config.in.mips
+++ b/arch/Config.in.mips
@@ -176,10 +176,10 @@ config BR2_MIPS_NAN_LEGACY
config BR2_MIPS_NAN_2008
bool
+ select BR2_ARCH_NEEDS_GCC_AT_LEAST_4_9
choice
prompt "Target NaN"
- depends on BR2_TOOLCHAIN_HAS_MNAN_OPTION
depends on BR2_mips_32r5 || BR2_mips_64r5
default BR2_MIPS_ENABLE_NAN_2008
help