summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBrent Generous <bgenerous@impinj.com>2019-08-04 17:07:07 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-08-04 17:37:56 +0200
commitd57e73078a315eb7419173d7e0503ce66c1df238 (patch)
tree6d5cd93b5536f85488e024fd9b3cd72853894ea9 /Makefile
parentcf65070365ab55664f12ffe85cae548d6b0f63da (diff)
Makefile: ensure $BINARIES_DIR exist before post-image scripts
When no filesystem is enabled, the $BINARIES_DIR is not created. Yet, the post-image scripts are still run. When those want to generate an image in there, they may fail as the dirctory does not exist (it did exist before we started applying preparatory changes for top-level parallel build, so scripts got to rely on that assumption). Do in target-post-image as we do in the sdk rule: create the directory before calling the scripts. Signed-off-by: Brent Generous <bgenerous@impinj.com> [yann.morin.1998@free.fr: - create the directory before calling the scripts - don't drop the creation in the sdk rule ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index bc5329bde3..f76d86a976 100644
--- a/Makefile
+++ b/Makefile
@@ -810,6 +810,7 @@ endif # merged /usr
.PHONY: target-post-image
target-post-image: $(TARGETS_ROOTFS) target-finalize staging-finalize
@rm -f $(ROOTFS_COMMON_TAR)
+ $(Q)mkdir -p $(BINARIES_DIR)
@$(foreach s, $(call qstrip,$(BR2_ROOTFS_POST_IMAGE_SCRIPT)), \
$(call MESSAGE,"Executing post-image script $(s)"); \
$(EXTRA_ENV) $(s) $(BINARIES_DIR) $(call qstrip,$(BR2_ROOTFS_POST_SCRIPT_ARGS))$(sep))