summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Hilliard <james.hilliard1@gmail.com>2018-12-12 10:20:04 +0800
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-13 21:58:42 +0100
commite49e811a88ad379543940464d74ba6422c018f4b (patch)
tree8ecf2f9ca041ad89507309e637bd6f7ecf7bcb82
parentf591f5826f58f5056985a998ccf01626c732ab5b (diff)
package/acpid: fix acpid.service permissions
Execution permissions cause systemd to throw runtime warnings since systemd service files are essentially a type of configuration file and are not designed to be executed like init scripts. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/acpid/acpid.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/acpid/acpid.mk b/package/acpid/acpid.mk
index 514fd31fe6..adcc1757aa 100644
--- a/package/acpid/acpid.mk
+++ b/package/acpid/acpid.mk
@@ -11,7 +11,7 @@ ACPID_LICENSE = GPL-2.0+
ACPID_LICENSE_FILES = COPYING
define ACPID_INSTALL_INIT_SYSTEMD
- $(INSTALL) -D -m 0755 package/acpid/acpid.service \
+ $(INSTALL) -D -m 0644 package/acpid/acpid.service \
$(TARGET_DIR)/usr/lib/systemd/system/acpid.service
mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
ln -sf ../../../../usr/lib/systemd/system/acpid.service \