summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-07-01 09:42:05 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-07-01 14:57:17 +0200
commitd5dcc76d9e5f9d22e881517ccc805dfd54499a74 (patch)
treebdcc8dc94d21423d4a45741e7f60518e9f387949
parent463e68d0581408caa9199a092c9fe8c000d9ed55 (diff)
core: always pass full path to strip command
In some cases, passing STRIP=true is not sufficient to disable striping altogether, as some (incorrectly generated?) configure scripts will ignore a ${STRIP} that is not a full path. This is the case, for example, for nmap, which ends up using the host strip command when we pass STRIP=true: checking for arm-buildroot-linux-gnueabihf-strip... no checking for strip... /usr/bin/strip configure: WARNING: using cross tools not prefixed with host triplet [--SNIP--] /usr/bin/install -c -c -m 755 nping /home/ymorin/dev/buildroot/O/target/usr/bin/nping /usr/bin/strip -x /home/ymorin/dev/buildroot/O/target/usr/bin/nping /usr/bin/strip: Unable to recognise the format of the input file `/home/ymorin/dev/buildroot/O/target/usr/bin/nping' We fix that by forcing a full path to the strip sommand when it is disabled: STRIP=/bin/true Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 4a3eb26963..c1dc714331 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -207,7 +207,7 @@ TARGET_STRIP = $(TARGET_CROSS)strip
STRIPCMD = $(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
endif
ifeq ($(BR2_STRIP_none),y)
-TARGET_STRIP = true
+TARGET_STRIP = /bin/true
STRIPCMD = $(TARGET_STRIP)
endif
INSTALL := $(shell which install || type -p install)