summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-09-27 08:41:21 +0200
committerChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-09-27 13:48:27 +0200
commitc2b4cc7855305ae6789b06b0734531f1f6e11bf4 (patch)
tree345b29fc257b6f5945318d561daa640514507075
parent38c5531c79759eb65054fb092731853828a04fb8 (diff)
uboot: Add Lion specific instructions.
To build mainline U-Boot for Lion, we need to copy the ATF binary to the build directory before building U-Boot. This patch allows to enable this step. Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
-rw-r--r--boot/uboot/Config.in6
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 9 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 336f659a39..ac621c995b 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -559,6 +559,12 @@ config BR2_TARGET_UBOOT_PUMA
help
Enable this option to include build steps required for the RK3399-Q7.
+config BR2_TARGET_UBOOT_LION
+ bool "RK3399-Q7 specific bootloader steps"
+ default y if BR2_TARGET_UBOOT_VERSION = "lion-v2019.04"
+ help
+ Enable this option to include build steps required for the RK3399-Q7.
+
config BR2_TARGET_UBOOT_PX30EVB
bool "PX30-EVB specific bootloader steps"
default y if BR2_TARGET_UBOOT_VERSION = "wip-px30"
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index f68bdbecfa..d88634567e 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -262,6 +262,9 @@ define UBOOT_BUILD_CMDS
cp -f $(BINARIES_DIR)/rk3399m0.bin $(@D)/rk3399m0.bin
cp -f $(BINARIES_DIR)/bl31.bin $(@D)/bl31-rk3399.bin
)
+ $(if $(BR2_TARGET_UBOOT_LION),
+ cp -f $(BINARIES_DIR)/bl31.bin $(@D)/bl31-rk3368.bin
+ )
$(if $(BR2_TARGET_UBOOT_PX30EVB),
cp -f $(BINARIES_DIR)/bl31.elf $(@D)/bl31.elf
)