summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-11-27 11:48:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-11-27 21:30:56 +0100
commitba6796c7ccb856fc34a7983c9ac031168f1e0b65 (patch)
tree77000cb31143a20da3f6a878068840d3ac52ad41
parentd8234d440024719e4df61f583b26302162dc363f (diff)
package/dvb-apps: is not parallel-safe
This is invisible because the timings make it excessively difficult to hit, but the Makefile is inherently flawed for parallel build, as it contains: $(objects): atsc_psip_section.c atsc_psip_section.h atsc_psip_section.c atsc_psip_section.h: perl section_generate.pl atsc_psip_section.pl and the perl script section_generate.pl will create both the .c and .h files in one go, but given the construct above, there can be two such script that run in parallel, which can clobber the generated .c and/or .h files. So, make dvb-apps a MAKE1 package. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/dvb-apps/dvb-apps.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/dvb-apps/dvb-apps.mk b/package/dvb-apps/dvb-apps.mk
index 8aa4a29307..ffab0db682 100644
--- a/package/dvb-apps/dvb-apps.mk
+++ b/package/dvb-apps/dvb-apps.mk
@@ -27,7 +27,7 @@ DVB_APPS_INSTALL_STAGING = YES
define DVB_APPS_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) LDLIBS="$(DVB_APPS_LDLIBS)" \
- $(MAKE) -C $(@D) CROSS_ROOT=$(STAGING_DIR) \
+ $(MAKE1) -C $(@D) CROSS_ROOT=$(STAGING_DIR) \
$(DVB_APPS_MAKE_OPTS)
endef