summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-12-03 22:05:08 +0100
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2018-12-04 21:53:14 +0100
commitac3b476bf5bfd04975d046dfba3336626d91c630 (patch)
treefc429c4657a9d272617b66ce011d232ae5849f9c
parentb67f0a99a94876280c3f5413225576e9e40c2fc8 (diff)
fs/common.mk: make sure that static devices from packages are created
The static devices defined by packages are currently added to the full device table when two conditions are met: (1) ROOTFS_DEVICE_TABLES is non-empty (2) BR2_ROOTFS_DEVICE_CREATION_STATIC=y (2) is obviously correct. However, depending on (1) is not correct: if the user doesn't provide any custom permission table and custom device table, then ROOTFS_DEVICE_TABLES will be empty. So instead, move the addition of the package-defined static devices outside of condition (1), and have it only under condition (2). Reported-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--fs/common.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 077ce8903e..a560417c6c 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -61,10 +61,10 @@ endif
$(call PRINTF,$(PACKAGES_PERMISSIONS_TABLE)) > $(ROOTFS_FULL_DEVICES_TABLE)
ifneq ($(ROOTFS_DEVICE_TABLES),)
cat $(ROOTFS_DEVICE_TABLES) >> $(ROOTFS_FULL_DEVICES_TABLE)
+endif
ifeq ($(BR2_ROOTFS_DEVICE_CREATION_STATIC),y)
$(call PRINTF,$(PACKAGES_DEVICES_TABLE)) >> $(ROOTFS_FULL_DEVICES_TABLE)
endif
-endif
rootfs-common-show-depends:
@echo $(ROOTFS_COMMON_DEPENDENCIES)