summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-09-18 21:02:00 +0200
committerChristoph Muellner <christoph.muellner@theobroma-systems.com>2019-09-27 08:24:28 +0200
commit81d33d97e0290fa0798f0cdc4bf833adf93d7a1a (patch)
tree84572e25d742415535e5be4feec6fb96af6bfc29
parentc2baa1d895d8d2e0b4365704fc1df2aa103f0161 (diff)
uboot: Add PX30-EVB specific instructions.
To build mainline U-Boot for PX30-EVB, we need to copy the ATF ELF to the build directory before building U-Boot. This patch allows to enable this step. Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
-rw-r--r--boot/uboot/Config.in6
-rw-r--r--boot/uboot/uboot.mk3
2 files changed, 9 insertions, 0 deletions
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 0c39a7557e..336f659a39 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -559,4 +559,10 @@ config BR2_TARGET_UBOOT_PUMA
help
Enable this option to include build steps required for the RK3399-Q7.
+config BR2_TARGET_UBOOT_PX30EVB
+ bool "PX30-EVB specific bootloader steps"
+ default y if BR2_TARGET_UBOOT_VERSION = "wip-px30"
+ help
+ Enable this option to include build steps required for the PX30EVB.
+
endif # BR2_TARGET_UBOOT
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index cb222aa6ec..f68bdbecfa 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -262,6 +262,9 @@ define UBOOT_BUILD_CMDS
cp -f $(BINARIES_DIR)/rk3399m0.bin $(@D)/rk3399m0.bin
cp -f $(BINARIES_DIR)/bl31.bin $(@D)/bl31-rk3399.bin
)
+ $(if $(BR2_TARGET_UBOOT_PX30EVB),
+ cp -f $(BINARIES_DIR)/bl31.elf $(@D)/bl31.elf
+ )
$(if $(UBOOT_CUSTOM_DTS_PATH),
cp -f $(UBOOT_CUSTOM_DTS_PATH) $(@D)/arch/$(UBOOT_ARCH)/dts/
)