summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValentin Korenblit <valentinkorenblit@gmail.com>2019-04-15 21:14:01 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2019-04-15 21:25:37 +0200
commit45d9a2b5bfe4feb144990ab4aa68eb03091e9a64 (patch)
treeff5adc44cc1e42fd8bee37d5b0146e6f666cf2ea
parent46cd7061228720ddb93f540bc733359304d8118f (diff)
package/clang: fix build with gcc < 5.1
Fixes: http://autobuild.buildroot.net/results/dc2302844a1d274e63da72023b6fd7be993f97b7 Signed-off-by: Valentin Korenblit <valentinkorenblit@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/clang/clang.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/clang/clang.mk b/package/clang/clang.mk
index 6dda8ac2c3..0cab1c7f89 100644
--- a/package/clang/clang.mk
+++ b/package/clang/clang.mk
@@ -15,6 +15,13 @@ CLANG_INSTALL_STAGING = YES
HOST_CLANG_DEPENDENCIES = host-llvm host-libxml2
CLANG_DEPENDENCIES = llvm host-clang
+# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
+# toolchain using gcc < 5.1 gives an error but actually still works. Setting
+# this option makes it still build with gcc >= 4.8.
+# https://reviews.llvm.org/D57264
+HOST_CLANG_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+CLANG_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+
# This option is needed, otherwise multiple shared libs
# (libclangAST.so, libclangBasic.so, libclangFrontend.so, etc.) will
# be generated. As a final shared lib containing all these components