summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorRicardo Martincoski <ricardo.martincoski@gmail.com>2018-11-04 02:12:07 -0200
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-08-03 17:17:29 +0200
commit4323fbaf8d203da5782d042d6f2fd399300ca03a (patch)
tree5b4b0d3d16b1950d9ca515fc1f33133016a2adad /.gitlab-ci.yml
parent8669243da3c4d6f86a912b5dfda9006e87789eec (diff)
support/testing: add test for check-package
Check the basic usage for check-package. It can be called using either absolute path, relative path or from PATH. Files to be checked can be passed with either absolute path or relative path (also including files in the current directory). Also check it ignores some special files when checking intree files, i.e. package/pkg-generic.mk, while still generating warnings for out-of-tree files when called with -b. In order to allow the later, add an empty line to the Config.in in the br2-external being tested so the script does generate a warning. Catches bug #11271. More tests can be added later, for example compatibility to Python 3. Suggested-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Cc: Arnout Vandecappelle <arnout@mind.be> [Arnout: wrap at 80 columns where appropriate; merge into a single class.] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml1
1 files changed, 1 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 3f2284d15f..fff9d99237 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -475,3 +475,4 @@ tests.toolchain.test_external.TestExternalToolchainLinaroArm: { extends: .runtim
tests.toolchain.test_external.TestExternalToolchainSourceryArmv4: { extends: .runtime_test }
tests.toolchain.test_external.TestExternalToolchainSourceryArmv5: { extends: .runtime_test }
tests.toolchain.test_external.TestExternalToolchainSourceryArmv7: { extends: .runtime_test }
+tests.utils.test_check_package.TestCheckPackageBasicUsage: { extends: .runtime_test }