summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
authorRicardo Martincoski <ricardo.martincoski@gmail.com>2018-03-13 00:09:44 -0300
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-03-31 22:48:29 +0200
commit1960eda2f681c16c22ab613fbd54a2aaa2a5e7dd (patch)
tree3edeabcdd2d2110cd861f8eede0dfa0891b6fdac /.gitlab-ci.yml
parent12b08c2be639e26ba0983d7dbdb3bddd91355f4c (diff)
.gitlab-ci.yml: check flake8
Add a test to check Python code style in the whole buildroot tree. Search files by type in order to help flake8 to find the Python scripts without .py extension. But don't rely only in the output of 'file' as it uses heuristics and sometimes it is wrong (specially identifying Python files as C++ source for the 'file' version currently in the Docker image). Include in the output: - the list of Python files processed; - statistics for each kind of warning; - the total number of warnings; - the number of Python files processed. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Yann E. MORIN <yann.morin.1998@free.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml11
1 files changed, 11 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 1f4d506196..fd1aeb3408 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -30,6 +30,17 @@ check-DEVELOPERS:
script:
- "! utils/get-developers | grep -v 'No action specified'"
+check-flake8:
+ before_script:
+ # Help flake8 to find the Python files without .py extension.
+ - find * -type f -name '*.py' > files.txt
+ - find * -type f -print0 | xargs -0 file | grep 'Python script' | cut -d':' -f1 >> files.txt
+ - sort -u files.txt | tee files.processed
+ script:
+ - python -m flake8 --statistics --count $(cat files.processed)
+ after_script:
+ - wc -l files.processed
+
check-package:
script:
- find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +