summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml.in
diff options
context:
space:
mode:
authorRicardo Martincoski <ricardo.martincoski@gmail.com>2018-04-01 02:08:50 -0300
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-04-01 10:16:35 +0200
commitb757f9aca356824e47ce2de27deb91b1992c0313 (patch)
tree7f03e1fe1d56dca1188ad52baca52f8f0e45804f /.gitlab-ci.yml.in
parent73dcbc19e9eb5a0c829ed7ee488ca4eaba17e337 (diff)
.gitlab-ci.yml: extend check-package test to Config.* files
Now that all issues in Config.in files have been fixed, let's try to make sure we don't introduce new ones by checking regularly these files issues in Gitlab CI. Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to '.gitlab-ci.yml.in')
-rw-r--r--.gitlab-ci.yml.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/.gitlab-ci.yml.in b/.gitlab-ci.yml.in
index bffcb02be1..fb2650c5ce 100644
--- a/.gitlab-ci.yml.in
+++ b/.gitlab-ci.yml.in
@@ -43,7 +43,8 @@ check-flake8:
check-package:
script:
- - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
+ - find . -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \)
+ -exec ./utils/check-package {} +
.defconfig: &defconfig
# Running the defconfigs for every push is too much, so limit to