summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml.in
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-11-30 00:08:45 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-12-01 23:00:02 +0100
commitb58059ad98984382934320235ce89faf0549062f (patch)
treec1ac6c15cf1639525b6cd15ecf3fad7ca2bddd74 /.gitlab-ci.yml.in
parentd55a3eb0e1b431cf495aa67bbd6aa7fee0697f10 (diff)
gitlab-ci: run check-package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to '.gitlab-ci.yml.in')
-rw-r--r--.gitlab-ci.yml.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/.gitlab-ci.yml.in b/.gitlab-ci.yml.in
index 33c7b13725..0d2e239414 100644
--- a/.gitlab-ci.yml.in
+++ b/.gitlab-ci.yml.in
@@ -30,6 +30,10 @@ check-DEVELOPERS:
script:
- "! utils/get-developers | grep -v 'No action specified'"
+check-package:
+ script:
+ - find . -type f -name '*.mk' -exec ./utils/check-package {} +
+
.defconfig: &defconfig
# Running the defconfigs for every push is too much, so limit to
# explicit triggers through the API.