summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-08-11 12:44:23 +0200
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>2018-08-12 14:39:32 +0200
commit1290241dc694b5435c47cb7065affbfa687d98cc (patch)
tree6e2ba72f7bdf6845ccf80f67fc901c21e45ab104 /.gitlab-ci.yml.in
parent6ca73d671e55ef06b752640d20af15b4c661268d (diff)
Makefile: introduce check-package target
The snippet of code that runs a check-package on all .mk/.hash/Config.in files is currently only available within .gitlab-ci.yml, and isn't immediately and easily usable by Buildroot users. In order to simplify this, this commit introduces a top-level "check-package" make target that implements the same logic. The .gitlab-ci.yml file is changed to use "make check-package". Since this target is oriented towards Buildroot developers, we intentionally do not clutter the already noisy "make help" text with this additional make target. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Reviewed-by: Ricardo Martincoski <ricardo.martincoski@gmail.com> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to '.gitlab-ci.yml.in')
-rw-r--r--.gitlab-ci.yml.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/.gitlab-ci.yml.in b/.gitlab-ci.yml.in
index fb2650c5ce..38e24c8d01 100644
--- a/.gitlab-ci.yml.in
+++ b/.gitlab-ci.yml.in
@@ -43,8 +43,7 @@ check-flake8:
check-package:
script:
- - find . -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \)
- -exec ./utils/check-package {} +
+ - make check-package
.defconfig: &defconfig
# Running the defconfigs for every push is too much, so limit to