summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-04-03 20:53:15 +0000
committerEric Fiselier <eric@efcs.ca>2017-04-03 20:53:15 +0000
commitf3b3a65d89b16a397882b3e88d50539a79919931 (patch)
treed06bd3ea8bab82ed67ff3322417bc1106b4a7f89 /CMakeLists.txt
parent9dcbb46826fd4d29b1485f25e8986d36019a6dca (diff)
suppress GCC warning about noexcept functions changing mangling
git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@299385 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffd8d532a..53904a16a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -466,7 +466,8 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
elseif("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
add_compile_flags_if_supported(
-Wno-literal-suffix
- -Wno-c++14-compat)
+ -Wno-c++14-compat
+ -Wno-noexcept-type)
endif()
if (LIBCXX_ENABLE_WERROR)
add_compile_flags_if_supported(-Werror)