summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2016-10-09 21:34:03 +0000
committerEric Fiselier <eric@efcs.ca>2016-10-09 21:34:03 +0000
commit3bf8a9cb678c26268c5d1ba6074f68632b825ca8 (patch)
tree11daf6e92f6847169ce3ff5a1b4ecc705f233439 /CMakeLists.txt
parent475cf023002ece7dc4e4906d7e9dccaa55b6f8a4 (diff)
Fix linker script generation for in-tree builds
git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@283700 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7e36334e..27cddec0f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -270,13 +270,13 @@ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${LIBCXX_LIBRARY_DIR})
# LIBCXX_CXX_FLAGS: General flags for both the compiler and linker.
# LIBCXX_COMPILE_FLAGS: Compile only flags.
# LIBCXX_LINK_FLAGS: Linker only flags.
-# LIBCXX_LIBRARIES: Private libraries libc++ is linked to.
-# LIBCXX_LIBRARIES_PUBLIC: Public libraries libc++ is linked to,
-# also exposed in the linker script.
+# LIBCXX_LIBRARIES: libraries libc++ is linked to.
+# LIBCXX_INTERFACE_LIBRARIES: Libraries that must be linked when using libc++
+# There libraries are exposed in the linker script.
set(LIBCXX_COMPILE_FLAGS "")
set(LIBCXX_LINK_FLAGS "")
set(LIBCXX_LIBRARIES "")
-set(LIBCXX_LIBRARIES_PUBLIC "")
+set(LIBCXX_INTERFACE_LIBRARIES "")
# Include macros for adding and removing libc++ flags.
include(HandleLibcxxFlags)