summaryrefslogtreecommitdiff
path: root/sysdeps/unix/sysv/linux/configure.ac
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-31 03:12:54 -0500
committerMike Frysinger <vapier@gentoo.org>2013-12-31 03:16:42 -0500
commitc8590f9d9edc8d2b8540586648fc9a0130da469e (patch)
tree4c7c1cc4004fb98455b8c956ab21797cd08da97b /sysdeps/unix/sysv/linux/configure.ac
parentdd1d85e5ddd6baaf99f53964a718fab85b160149 (diff)
tst-fanotify: check for linux/fanotify.h existence
We support older kernels that lack this header, so check for it before we try to use it. Reported-by: Adhemerval Zanella <azanella@linux.vnet.ibm.com> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sysdeps/unix/sysv/linux/configure.ac')
-rw-r--r--sysdeps/unix/sysv/linux/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysdeps/unix/sysv/linux/configure.ac b/sysdeps/unix/sysv/linux/configure.ac
index 1be921f65e..6d6053f27e 100644
--- a/sysdeps/unix/sysv/linux/configure.ac
+++ b/sysdeps/unix/sysv/linux/configure.ac
@@ -105,6 +105,12 @@ else
*** compatible kernel version])
fi
+# Until we start requiring 2.6.37+ headers, we need to check for the
+# availability of linux/fanotify.h for testing purposes.
+AC_CHECK_HEADER(linux/fanotify.h,
+ [DEFINES="$DEFINES -DHAVE_LINUX_FANOTIFY_H=1"], ,
+ [/* No default includes. */])
+
# The result of the above test for the use of the FDE code is invalid if
# the user overrides the decision about the minimum ABI.
if test "$oldest_abi" != default && test "2.2.4" \< "$oldest_abi"; then