summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-30 08:14:15 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2001-03-30 08:14:15 +0000
commitfc232ea3614f286271b944ea9ad251c463ef88d0 (patch)
tree6976a32efc4fef22cdaf1ce7224cc059678b178d /libstdc++-v3/Makefile.am
parentc1edfa530d86aea0ea3af0e91df9537d1fe5d5ae (diff)
2001-03-28 Benjamin Kosnik <bkoz@redhat.com>
* mkcheck.in (LIBTOOL): Don't construct -B argument here... * tests_flags.in (CXX): Construct here. (static_fail): Don't remove compile.out. Format with spaces. (INCLUDES): Deal with xcompiling. * configure.in (xcompiling): Substitute. * testsuite/Makefile.am: Snake libjava configury. * testsuite/Makefile.in: Regenerate. * testsuite/23_containers/map_operators.cc: Tweaks. * testsuite/23_containers/set_operators.cc: Tweaks. 2001-03-28 Gabriel Dos Reis <gdr@merlin.codesourcery.com> Enable dejagnu testing framework. * configure.in: Generate testsuite/Makefile. * configure: Regenerate. * Makefile.am (check-install): Change rule from this... (check-script-install): ...to this. (check): Change rule from this... (check-script):...to this. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@40960 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index 9681725d8cb0..b7985ffa4b3c 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -24,20 +24,20 @@
AUTOMAKE_OPTIONS = 1.3 cygnus
MAINT_CHARSET = latin1
-SUBDIRS = libio libmath libsupc++ src
+SUBDIRS = libio libmath libsupc++ src testsuite
mkinstalldirs = $(SHELL) $(toplevel_srcdir)/mkinstalldirs
# Use $${builddir} instead of $(top_builddir) for arguments to "mkcheck"
# because then the paths will be full pathnames, not relative
# pathnames. (-Wl,--rpath seems to like this better.)
-check: $(top_builddir)/mkcheck
+check-script: $(top_builddir)/mkcheck
-(chmod + $(top_builddir)/mkcheck; \
srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \
cd testsuite; $${builddir}/mkcheck 0 $${builddir} $${srcdir})
-check-install: $(top_builddir)/mkcheck
+check-script-install: $(top_builddir)/mkcheck
-(chmod + $(top_builddir)/mkcheck; \
srcdir=`cd $(top_srcdir); pwd`; builddir=`pwd`; \
test -d testsuite || (mkdir testsuite; chmod u+w testsuite); \