summaryrefslogtreecommitdiff
path: root/libstdc++-v3/Makefile.am
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-17 05:46:01 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-17 05:46:01 +0000
commita167a2a416d7427d604aced7bb9adfd42d4654ad (patch)
tree723f37102561df2c4d59fe789bc783d9853c641c /libstdc++-v3/Makefile.am
parenta0ed384df74326c3c6743e523ae3de8eddfd1547 (diff)
03-06-16 Benjamin Kosnik <bkoz@redhat.com>
* Makefile.am (check-abi): Move... (new-abi-baseline): Move... * testsuite/Makefile.am: ...here. (new-abi-baseline): Conditionalize. (check-abi): Conditionalize. (check-abi-verbose): New. * Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate. * configure.in: Consolidate testsuite configure bits. * acinclude.m4 (GLIBCPP_CONFIGURE_TESTSUITE): Same. * configure: Regenerate. * aclocal.m4: Regenerate. * testsuite/abi_check.cc: Add --check-verbose. Only output detailed information if --check-verbose. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@68067 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/Makefile.am')
-rw-r--r--libstdc++-v3/Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/libstdc++-v3/Makefile.am b/libstdc++-v3/Makefile.am
index d17784bdea3c..58edd36937ae 100644
--- a/libstdc++-v3/Makefile.am
+++ b/libstdc++-v3/Makefile.am
@@ -46,26 +46,6 @@ check-script-install: $(top_builddir)/mkcheck
cd testsuite; \
@glibcpp_builddir@/mkcheck 1)
-# Use 'new-abi-baseline' to create an initial symbol file. Then run
-# 'check-abi' to test for changes against that file.
-baseline_file = @baseline_file@
-check-abi: $(top_builddir)/testsuite/abi_check
- -@(cd testsuite; \
- @glibcpp_srcdir@/config/abi/extract_symvers \
- ../src/.libs/libstdc++.so \
- ./current_symbols.txt && \
- ./abi_check --check ./current_symbols.txt ${baseline_file})
-
-new-abi-baseline:
- -@(output=${baseline_file}; \
- if test -f $${output}; then \
- output=$${output}.new; \
- t=`echo $${output} | sed 's=.*config/abi/=='`; \
- echo "Baseline file already exists, writing to $${t} instead."; \
- fi; \
- @glibcpp_srcdir@/config/abi/extract_symvers \
- src/.libs/libstdc++.so $${output})
-
# These rules are messy, but are hella worth it.
doxygen:
-(srcdir=`cd ${top_srcdir}; ${PWD}`; \