summaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2015-09-15 21:15:37 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2015-09-15 21:15:37 +0000
commit242418a3cc155e06411da3b5e7aff50622d12ad4 (patch)
treecc1561d9c684e30e43f7804a87ab7caab0047110 /libgo/Makefile.am
parentf12cf9f46d07a0a6fd7ed088d3fd7e8562a56001 (diff)
libgo: If compiler can split-stack and linker can not, use -fno-split-stack.
If the compiler supports split-stack but we are using a gold linker that does not, as happens on PPC with current GCC but old gold, then we need to compile the Go code with -fno-split-stack to avoid a linker error avoid the inability to call from split-stack code to non-split-stack code. Reviewed-on: https://go-review.googlesource.com/14598 git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@227811 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 924dba0a705b..ca2280dcecf7 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -2074,7 +2074,7 @@ libnetgo_a_LIBADD = netgo.o
LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
GOCFLAGS = $(CFLAGS)
-AM_GOCFLAGS = $(STRINGOPS_FLAG)
+AM_GOCFLAGS = $(STRINGOPS_FLAG) $(GO_SPLIT_STACK)
GOCOMPILE = $(GOC) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_GOCFLAGS) $(GOCFLAGS)
LTGOCOMPILE = $(LIBTOOL) --tag GO --mode=compile $(GOC) $(INCLUDES) \