summaryrefslogtreecommitdiff
path: root/libdecnumber/configure.ac
diff options
context:
space:
mode:
authorAndreas Krebbel <Andreas.Krebbel@de.ibm.com>2010-09-03 13:30:58 +0000
committerAndreas Krebbel <Andreas.Krebbel@de.ibm.com>2010-09-03 13:30:58 +0000
commit0b51ce00751290f667de07ef28240a5af946bd91 (patch)
treedbdbb1da253d964a767941448e24a1097328e3b0 /libdecnumber/configure.ac
parentb04bc5d4a7c4c93ef96e0da2b0e0f22a9e772270 (diff)
libdecnumber/
2010-09-03 Andreas Krebbel <Andreas.Krebbel@de.ibm.com> * configure.ac: Use the GCC_AC_ENABLE_DECIMAL_FLOAT macro. * Makefile.in: Add aclocal.m4 dependency to dfp.m4. * configure: Regenerate. * aclocal.m4: Regenerate. config/ 2010-09-03 Andreas Krebbel <Andreas.Krebbel@de.ibm.com> * dfp.m4: New file.
Diffstat (limited to 'libdecnumber/configure.ac')
-rw-r--r--libdecnumber/configure.ac38
1 files changed, 2 insertions, 36 deletions
diff --git a/libdecnumber/configure.ac b/libdecnumber/configure.ac
index 4d9060f5cd..a4cbf55f1a 100644
--- a/libdecnumber/configure.ac
+++ b/libdecnumber/configure.ac
@@ -75,42 +75,8 @@ AC_CANONICAL_TARGET
# Default decimal format
# If you change the defaults here, be sure to change them in the GCC directory also
AC_MSG_CHECKING([for decimal floating point])
-AC_ARG_ENABLE(decimal-float,
-[ --enable-decimal-float={no,yes,bid,dpd}
- enable decimal float extension to C. Selecting 'bid'
- or 'dpd' choses which decimal floating point format
- to use],
-[
- case $enable_decimal_float in
- yes | no | bid | dpd) ;;
- *) AC_MSG_ERROR(['$enable_decimal_float' is an invalid value for --enable-decimal-float.
-Valid choices are 'yes', 'bid', 'dpd', and 'no'.]) ;;
- esac
-],
-[
- case $target in
- powerpc*-*-linux* | i?86*-*-linux* | x86_64*-*-linux*)
- enable_decimal_float=yes
- ;;
- *)
- enable_decimal_float=no
- ;;
- esac
-])
-
-# x86's use BID format instead of DPD
-# In theory --enable-decimal-float=no should not compile anything
-# For the sake of simplicity, just use the default format in this directory
-if test x$enable_decimal_float = xyes -o x$enable_decimal_float = xno; then
- case $target in
- i?86*-*-linux* | x86_64*-*-linux*)
- enable_decimal_float=bid
- ;;
- *)
- enable_decimal_float=dpd
- ;;
- esac
-fi
+
+GCC_AC_ENABLE_DECIMAL_FLOAT([$target])
# If BID is being used, additional objects should be linked in.
if test x$enable_decimal_float = xbid; then