summaryrefslogtreecommitdiff
path: root/gdb/testsuite/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tromey@redhat.com>2009-06-29 16:41:45 +0000
committerTom Tromey <tromey@redhat.com>2009-06-29 16:41:45 +0000
commit6bc80edc986a7afe2389deac4f18e8c1b976b66c (patch)
treec5618f0beaadc2db35c7cb4fb463ca9fc3cb94b9 /gdb/testsuite/configure.ac
parent794684b64f780fbecb3443d6783284919c83c07f (diff)
gdb
* README: Mention parallel check. gdb/testsuite * dg-extract-results.sh: New file. * Makefile.in (FORCE_PARALLEL): New variable. (CHECK_TARGET): New conditional variable. (check): Use CHECK_TARGET. (DO_RUNTEST): New variable. (check-single): New target. (TEST_DIRS): New variable. (TEST_TARGETS): Likewise. (check-parallel): New target. (check-gdb.%): New pattern. (BASE1_FILES): New variable. (BASE2_FILES): Likewise. (check-gdb.base%): New pattern. (%/.dir): New pattern. * configure: Rebuild. * aclocal.m4 (AM_CONDITIONAL): New defun. * configure.ac: Check whether user is using GNU make. (GMAKE): New conditional.
Diffstat (limited to 'gdb/testsuite/configure.ac')
-rw-r--r--gdb/testsuite/configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/gdb/testsuite/configure.ac b/gdb/testsuite/configure.ac
index bb98e6f79f..80d89aa47e 100644
--- a/gdb/testsuite/configure.ac
+++ b/gdb/testsuite/configure.ac
@@ -1,7 +1,7 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-# Copyright 2002, 2003, 2004, 2005
+# Copyright 2002, 2003, 2004, 2005, 2009
# Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or modify
@@ -26,6 +26,17 @@ AC_CANONICAL_TARGET
ACX_NONCANONICAL_TARGET
+# Check for the 'make' the user wants to use.
+AC_CHECK_PROGS(MAKE, make)
+MAKE_IS_GNU=
+case "`$MAKE --version 2>&1 | sed 1q`" in
+ *GNU*)
+ MAKE_IS_GNU=yes
+ ;;
+esac
+AM_CONDITIONAL(GMAKE, test "$MAKE_IS_GNU" = yes)
+AC_PROG_MAKE_SET
+
# Add HP-specific tests when appropriate.
case $target in
hppa*-*-hpux*)