summaryrefslogtreecommitdiff
path: root/gdb/testsuite/configure.ac
diff options
context:
space:
mode:
authorPedro Alves <palves@redhat.com>2014-08-20 18:55:54 +0100
committerPedro Alves <palves@redhat.com>2014-08-20 18:55:54 +0100
commit2a31c6236de308f7109720230e70b96c5d5b966a (patch)
treec4c1558ae44aad7c21c6a30d6f5b3b4c7ac44dec /gdb/testsuite/configure.ac
parent469a34932ae4208240e98c843b01ea1f00892137 (diff)
Integrate PR 12649's race detector directly in the testsuite machinery
This integrates Jan Kratochvil's nice race reproducer from PR testsuite/12649 into the testsuite infrustructure directly. With this, one only has to do either 'make check-read1' or 'make check READ1="1"' to preload the read1.so library into expect. Currently only enabled for glibc/GNU systems, and if build==host==target. gdb/testsuite/ChangeLog: * Makefile.in (EXTRA_RULES, CC): New variables, get from configure. (EXPECT): Handle READ1 being set. (all): Depend on EXTRA_RULES. (check-read1, expect-read1, read1.so, read1): New rules. * README (Testsuite Parameters): Document the READ1 make variable. (Race detection): New section. * configure: Regenerate. * configure.ac: If build==host==target, and running under a GNU/glibc system, add read1 to the extra Makefile rules. (EXTRA_RULES): AC_SUBST it. * lib/read1.c: New file. gdb/ChangeLog: * Makefile.in (check-read1): New rule.
Diffstat (limited to 'gdb/testsuite/configure.ac')
-rw-r--r--gdb/testsuite/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/gdb/testsuite/configure.ac b/gdb/testsuite/configure.ac
index fb084d48fd..9dccc9fab8 100644
--- a/gdb/testsuite/configure.ac
+++ b/gdb/testsuite/configure.ac
@@ -87,6 +87,15 @@ AC_CHECK_HEADERS(pthread.h)
AC_EXEEXT
+if test "${build}" = "${host}" -a "${host}" = "${target}"; then
+ case "${host}" in
+ *gnu*)
+ EXTRA_RULES=read1
+ ;;
+ esac
+fi
+AC_SUBST(EXTRA_RULES)
+
AC_OUTPUT([Makefile \
gdb.ada/Makefile \
gdb.arch/Makefile gdb.asm/Makefile gdb.base/Makefile gdb.btrace/Makefile \