summaryrefslogtreecommitdiff
path: root/gdb/gdbserver/configure.ac
diff options
context:
space:
mode:
authorGary Benson <gbenson@redhat.com>2016-01-18 09:45:10 +0000
committerGary Benson <gbenson@redhat.com>2016-01-18 11:39:42 +0000
commiteb0edac83f82516bbbd5a0412bbdf7fd27c687f2 (patch)
treee1e7a87000a8f625cf64fa551df6ed2305394313 /gdb/gdbserver/configure.ac
parent760f6ee894c5f473777c7ff5ebe5a04b25651ce4 (diff)
Fix gdbserver build failure on targets without fork
This commit fixes nat/linux-namespaces.c to build correctly on targets without fork. gdb/ChangeLog: * nat/linux-namespaces.c (do_fork): New function. (linux_mntns_get_helper): Use the above. gdb/gdbserver/ChangeLog: * configure.ac (AC_FUNC_FORK): New check. * config.in: Regenerate. * configure: Likewise.
Diffstat (limited to 'gdb/gdbserver/configure.ac')
-rw-r--r--gdb/gdbserver/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/gdb/gdbserver/configure.ac b/gdb/gdbserver/configure.ac
index 8476fbdcbd..f15ee1f871 100644
--- a/gdb/gdbserver/configure.ac
+++ b/gdb/gdbserver/configure.ac
@@ -94,6 +94,7 @@ AC_CHECK_HEADERS(sgtty.h termio.h termios.h sys/reg.h string.h dnl
fcntl.h signal.h sys/file.h dnl
sys/ioctl.h netinet/in.h sys/socket.h netdb.h dnl
netinet/tcp.h arpa/inet.h)
+AC_FUNC_FORK
AC_CHECK_FUNCS(getauxval pread pwrite pread64 setns)
GDB_AC_COMMON