summaryrefslogtreecommitdiff
path: root/gdb/gdbserver/configure.ac
diff options
context:
space:
mode:
authorPedro Alves <palves@redhat.com>2013-07-01 11:19:27 +0000
committerPedro Alves <palves@redhat.com>2013-07-01 11:19:27 +0000
commitbc7dea8de974648cd4e38d154abcca6879e630cc (patch)
tree04a5357b0560fa7271fc532290aeab6f04ded93c /gdb/gdbserver/configure.ac
parent8839a007adc2aaf3a5278cbe8e0e85f827360a87 (diff)
Rely on gnulib's unistd.h replacement.
With gnulib's unistd module, we can assume unistd.h is always present, and that STDIN_FILENO, STDOUT_FILENO, STDERR_FILENO are always defined. Don't remove unistd.h from GDB's configure.ac, as later tests in the file use HAVE_UNISTD_H checks. gdb/ 2013-07-01 Pedro Alves <palves@redhat.com> * defs.h: Don't check HAVE_UNISTD_H before including <unistd.h>. (STDIN_FILENO, STDOUT_FILENO, STDERR_FILENO): Delete. * tracepoint.c: Don't check HAVE_UNISTD_H before including <unistd.h>. gdb/gdbserver/ 2013-07-01 Pedro Alves <palves@redhat.com> * event-loop.c: Don't check HAVE_UNISTD_H before including <unistd.h>. * gdbreplay.c: Likewise. * remote-utils.c: Likewise. * server.c: Likewise. * configure.ac: Don't check for unistd.h. * configure: Regenerate.
Diffstat (limited to 'gdb/gdbserver/configure.ac')
-rw-r--r--gdb/gdbserver/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/gdbserver/configure.ac b/gdb/gdbserver/configure.ac
index c983d41ff3..2658bef21f 100644
--- a/gdb/gdbserver/configure.ac
+++ b/gdb/gdbserver/configure.ac
@@ -65,7 +65,7 @@ ACX_CONFIGURE_DIR(["../gnulib"], ["build-gnulib-gdbserver"])
AC_CHECK_HEADERS(sgtty.h termio.h termios.h sys/reg.h string.h dnl
proc_service.h sys/procfs.h thread_db.h linux/elf.h dnl
- stdlib.h unistd.h dnl
+ stdlib.h dnl
errno.h fcntl.h signal.h sys/file.h malloc.h dnl
sys/ioctl.h netinet/in.h sys/socket.h netdb.h dnl
netinet/tcp.h arpa/inet.h sys/wait.h wait.h sys/un.h dnl