summaryrefslogtreecommitdiff
path: root/gdb/gdbserver/configure.ac
diff options
context:
space:
mode:
authorSimon Marchi <simon.marchi@ericsson.com>2016-02-09 09:01:58 -0500
committerSimon Marchi <simon.marchi@ericsson.com>2016-02-09 09:01:58 -0500
commit1e94266c4db633f7defaf4bb68c74fd09a9cf9e2 (patch)
treed5e184312fa541f34cad8c389f124c176a4c96ea /gdb/gdbserver/configure.ac
parent2a7f3dffced7a20c992e1488d9f05fed8b8001fd (diff)
Modernize configure.ac's
Using AC_OUTPUT with arguments has been deprecated for some time in autoconf, even in version 2.64, which we are using. This change should not affect functionality. I also removed the "exit 0"'s, they shouldn't be necessary. gdb/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. Remove "exit 0" at the end. * configure: Regenerate. gdb/testsuite/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. * configure: Regenerate. gdb/gdbserver/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. * configure: Regenerate.
Diffstat (limited to 'gdb/gdbserver/configure.ac')
-rw-r--r--gdb/gdbserver/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/gdb/gdbserver/configure.ac b/gdb/gdbserver/configure.ac
index f15ee1f871..627c590438 100644
--- a/gdb/gdbserver/configure.ac
+++ b/gdb/gdbserver/configure.ac
@@ -473,9 +473,11 @@ if test x"$STDINT_H" != x; then
fi
AC_SUBST(GNULIB_STDINT_H)
-AC_OUTPUT(Makefile,
+AC_CONFIG_FILES([Makefile],
[case x$CONFIG_HEADERS in
xconfig.h:config.in)
echo > stamp-h ;;
esac
])
+
+AC_OUTPUT