summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorPedro Alves <palves@redhat.com>2016-01-05 11:03:40 +0000
committerPedro Alves <palves@redhat.com>2016-01-05 11:03:40 +0000
commit976102cd178de0dd6b366746f850b026a2793097 (patch)
treea932ea2ef31728b3c5700e38851a50ebefa8fdeb /gdb/configure.ac
parent44ddb0c66aa268f0027665da61273e78c9d748ae (diff)
Fix PR sim/13418: building with --enable-targets=all fails
Multitarget builds currently fail when: (1) simulator support is enabled (the main --target supports target sim) (2) powerpc is included in the --enable-targets list (3) powerpc is not the main/default target (--target) This is because the powerpc sim provides a non-standard API function sim_spr_register_name which gdb/rs6000-tdep.c utilizes. Since the sim does not yet support multitarget, only the sim (if one exists) for the main target is built. When that target isn't powerpc, this function is not available leading to linking errors: rs6000-tdep.c:(.text+0x1e34d): undefined reference to `sim_spr_register_name' Fix this by only using that API if the sim linked in is the powerpc sim. gdb/ChangeLog: 2016-01-05 Pedro Alves <palves@redhat.com> PR sim/13418 * configure.ac: Define WITH_PPC_SIM when linking in the sim and the target is powerpc*. * configure: Regenerate. * config.in: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 5b618c97f9..d1026406a6 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -2260,6 +2260,14 @@ if test "${ignore_sim}" = "false"; then
SIM="${gdb_sim}"
SIM_OBS="remote-sim.o"
AC_DEFINE(WITH_SIM, 1, [Define if the simulator is being linked in.])
+
+ # Some tdep code should only be compiled in when the ppc sim is
+ # built. PR sim/13418.
+ case $target in
+ powerpc*-*-*)
+ AC_DEFINE(WITH_PPC_SIM, 1, [Define if the PPC simulator is being linked in.])
+ ;;
+ esac
fi
fi
AC_SUBST(SIM)