summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorSimon Marchi <simon.marchi@ericsson.com>2016-02-09 09:01:58 -0500
committerSimon Marchi <simon.marchi@ericsson.com>2016-02-09 09:01:58 -0500
commit1e94266c4db633f7defaf4bb68c74fd09a9cf9e2 (patch)
treed5e184312fa541f34cad8c389f124c176a4c96ea /gdb/configure.ac
parent2a7f3dffced7a20c992e1488d9f05fed8b8001fd (diff)
Modernize configure.ac's
Using AC_OUTPUT with arguments has been deprecated for some time in autoconf, even in version 2.64, which we are using. This change should not affect functionality. I also removed the "exit 0"'s, they shouldn't be necessary. gdb/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. Remove "exit 0" at the end. * configure: Regenerate. gdb/testsuite/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. * configure: Regenerate. gdb/gdbserver/ChangeLog: * configure.ac: Use AC_CONFIG_FILES instead of passing arguments to AC_OUTPUT. * configure: Regenerate.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index a7b7421ced..70452d3ff0 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -2333,8 +2333,7 @@ AC_DEFINE(GDB_DEFAULT_HOST_CHARSET, "UTF-8",
GDB_AC_TRANSFORM([gdb], [GDB_TRANSFORM_NAME])
GDB_AC_TRANSFORM([gcore], [GCORE_TRANSFORM_NAME])
AC_CONFIG_FILES([gcore], [chmod +x gcore])
-
-AC_OUTPUT(Makefile gdb-gdb.gdb doc/Makefile data-directory/Makefile,
+AC_CONFIG_FILES([Makefile gdb-gdb.gdb doc/Makefile data-directory/Makefile],
[
case x$CONFIG_HEADERS in
xconfig.h:config.in)
@@ -2342,4 +2341,4 @@ echo > stamp-h ;;
esac
])
-exit 0
+AC_OUTPUT