summaryrefslogtreecommitdiff
path: root/binutils/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2014-12-11 16:02:35 +1030
committerAlan Modra <amodra@gmail.com>2014-12-11 17:07:46 +1030
commit4c219c2e69bb66a5535645e2c83fafda1362acea (patch)
tree10dd7e49bfa50e1c721ee6b938330e0c9884960e /binutils/configure.ac
parent1b43a4392f2c979e77a9fef16877ec99b9cf26a3 (diff)
Use autoconf check for long long in binutils
Also fix a place where %lld was wrongly used to print a dwarf_vma. * configure.ac: Check for long long and sizes of long long and long. * elfcomm.h (HOST_WIDEST_INT): Test HAVE_LONG_LONG in place of __STDC_VERSION__ and __GNUC__. * strings.c (print_strings): Likewise. * dwarf.c (DWARF_VMA_FMT, DWARF_VMA_FMT_LONG): Likewise. (read_debug_line_header): Use dwarf_vmatoa to print warning. * configure: Regenerate. * config.in: Regenerate.
Diffstat (limited to 'binutils/configure.ac')
-rw-r--r--binutils/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/binutils/configure.ac b/binutils/configure.ac
index 84c287c69a..b85a9d2436 100644
--- a/binutils/configure.ac
+++ b/binutils/configure.ac
@@ -124,6 +124,9 @@ case "${host}" in
esac
AC_SUBST(DEMANGLER_NAME)
+AC_CHECK_SIZEOF([long])
+AC_CHECK_TYPES([long long], [AC_CHECK_SIZEOF(long long)])
+
AC_CHECK_HEADERS(string.h strings.h stdlib.h unistd.h fcntl.h sys/file.h limits.h locale.h sys/param.h wchar.h)
AC_HEADER_SYS_WAIT
ACX_HEADER_STRING